composer

06.07.19 - 18:59

The requested package egulias/email-validator (locked at 1.2.15, required as ^2.0) is satisfiable by egulias/email-validator[1.2.15] but these conflict with your requirements or minimum-stability

Oh wow. I found a solution. I'm sure it is not the correct solution but it does work. From within your drupal directory, open core/composer.json.

Search for "egulias/email-validator". Change the version to "^2.0".

Run composer update egulias/email-validator drupal/core --with-dependencies

So many wasted hours chasing down why Composer does not update.

Установка Drush 8 на BeGet

Здесь я записывал кое-что про установку Drush 8 на хостинге BeGet для дальнейшей работы с Drupal 8

Из папки сайта public_html набрал это: composer global require drush/drush при этом захожу не из Docker. Устанавливается 7 версия Drush

/usr/local/php-cgi/5.6/bin/php ~/.local/bin/composer.phar global require drush/drush:8.* - установка из папки сайта composer и drush 8 сразу